Как присвоить имя диапазону в Microsoft Excel

Вы постоянно ссылаетесь на одни и те же диапазоны ячеек в рабочей книге? Excel предлагает именованный диапазон, который является превосходным способом ссылки на диапазон ячеек.

Если, например, есть данные о продажах в ячейках C3:C14, на которые вы постоянно ссылаетесь, можете создать именованный диапазон под названием ПродажиМесяца и использовать его вместо диапазона ячеек C3:C14. В этой статье мы расскажем обо всех способах добавления имени к диапазонам в Excel.

Зачем использовать именованные диапазоны в Microsoft Excel?

Именованный диапазон сделает расчеты в Excel более понятными как для вас, так и для других. Формула, содержащая именованный диапазон, например =СУММ(ПродажиМесяца), позволяет лучше понять суть вычислений по сравнению с =СУММ(C3:C14).


Именованный диапазон также гораздо легче обновить, если диапазон ячеек изменится. Если именованный диапазон ПродажиМесяца должен указывать на ячейки D3:D14 вместо C3:C14, вам придется обновить именованный диапазон только в одном месте. Не нужно будет обновлять формулы или код!

Какие имена можно использовать?

Существует несколько правил при присвоении имени диапазону:

  • Имя не может превышать 255 символов;
  • Имена должны начинаться с буквы, подчеркивания _ или обратной косой черты \;
  • Избегайте специальных символов, кроме подчеркивания _ и точки ;
  • В имени нельзя использовать пробел;
  • Соединяйте слова вместе и вместо этого пишите их первые буквы заглавными;
  • Нельзя использовать имя, которое также может быть ссылкой на ячейку. Имя Hi5 может также ссылаться на ячейку HI5, поэтому нельзя использовать такие имена;
  • Избегайте создания имени, которое уже используется. Именованные диапазоны, имеющие область видимости рабочего листа, могут иметь одинаковые имена, но это может запутать.

Именование диапазона на вкладке Формулы

Вы можете создать именованный диапазон с помощью ленты Excel. Предположим, вы хотите создать именованный диапазон для всех ежемесячных продаж:

  • Выделите ячейки, которые хотите включить в именованный диапазон;
  • Перейдите на вкладку Формулы и выберите команду Присвоить имя;
  • Введите имя для диапазона в поле Имя;
  • Оставьте параметр Область как Книга, чтобы он был доступен на каждом листе;
  • В поле Примечание оставьте необязательное описание;
  • Поле Диапазон уже должно быть предварительно заполнено выбранными ячейками;
  • У вас есть возможность выбрать другой диапазон ячеек. Нажмите OK, чтобы вернуться на лист.

Теперь у вас есть именованный диапазон, представляющий выбранные ячейки!


Именование диапазона из меню правой кнопки мыши

Вы можете создать именованный диапазон с помощью меню правой кнопки мыши:

  • Выберите ячейки, которые будут включены в именованный диапазон;
  • Щелкните правой кнопкой мыши и выберите команду «Присвоить имя…»;
  • Повторите все шаги из инструкции выше.

Именование диапазона из диспетчера имен

Диспетчер имен — это централизованное местоположение всех именованных диапазонов. Чтобы создать именованный диапазон с помощью Диспетчера имен:

  • Перейдите на вкладку ленты Формулы и выберите Диспетчер имен;
  • Нажмите Создать…;
  • Определите именованный диапазон, как описано в разделе статьи выше;
  • Посмотрите, как новый именованный диапазон теперь появляется в списке Диспетчера имен;
  • Нажмите Закрыть, чтобы вернуться к листу.

Именование нескольких диапазонов с помощью функции Создать из выделенного

Создание именованных диапазонов особенно быстро, если данные расположены в виде таблицы с заголовками столбцов. Чтобы создать именованный диапазон для каждого столбца, выполните следующие действия:


  • Выделите данные и убедитесь, что они включают заголовки столбцов;
  • Перейдите на вкладку ленты Формулы и выберите Создать из выделенного.Установите флажок В строке выше, чтобы использовать заголовки столбцов в качестве имен именованных диапазонов;
  • После этого нажмите кнопку OK.

Теперь у вас есть именованный диапазон для каждого столбца данных!

Именование диапазона с помощью сочетания клавиш

Excel предоставляет две комбинации клавиш, которые помогут создать именованные диапазоны:

  • Нажмите Ctrl + F3 на листе, чтобы быстро открыть Диспетчер имен;
  • Нажмите Ctrl + Shift + F3 на листе, и откроется окно «Создать из выделенного» без необходимости навигации.

Используйте эти методы для создания именованных диапазонов для любых ячеек, на которые вы будете ссылаться снова и снова. Вы и ваши пользователи выиграют от того, что рабочая книга будет легка для понимания. Поиск также станет проще, учитывая все представленные варианты, которые помогут найти именованные диапазоны.

Подписаться
Уведомить о
0 комментариев
Межтекстовые Отзывы
Посмотреть все комментарии